Installation

Server Requirements

  • PHP 5.3.3+ (We recommend 5.5.0+)
  • MCrypt PHP Extension

Install Composer

Install Composer Tomahawk uses Composer to manage its dependencies. You can download it here.


Download Tomahawk Standard

Tomahawk Standard is the front end to the framework. It contains all your config files, views, controllers etc.

You can download it here. Extract the zipped file to the directory you'll be running the site from.

Now you can install the Tomahawk Framework


Install the Framework and Dependencies

Run the following command in the directory where Tomahawk Standard is:

composer install

You now have TomahawKPHP installed!

Open your project in a text editor and open app/config/request.php

Change the host and port values to your required needs and open in a web browser.